Tasklist

FS#72 - efikamx devices

Attached to Project: CRUX-ARM
Opened by Manson (Manson) - Friday, 12 June 2015, 18:13 GMT
Last edited by Victor Martinez (pitillo) - Monday, 13 July 2015, 06:30 GMT
Task Type Bug Report
Category ports/efikamx-arm
Status Closed
Assigned To Victor Martinez (pitillo)
Operating System CRUX-ARM
Severity Low
Priority Normal
Reported Version 2.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Current libgmp version 5.0.5 fails with assembler error.

The problem is located on upstream Pkgfile which forces the build for i686.
[...]
tmp-add_n.s: Assembler messages:
tmp-add_n.s:79: Error: bad instruction `xor %edx,%edx'
[...]

From the original Pkgfile, it specifies:
--build=i686-pc-linux-gnu

Solution:
- Use current build vars for both ABI's:
- softfp: --build=arm-unknown-linux-gnueabi
This task depends upon

Closed by  Victor Martinez (pitillo)
Monday, 13 July 2015, 06:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Commented
Comment by Victor Martinez (pitillo) - Monday, 13 July 2015, 06:27 GMT
Hello Manson,
I can't see any problem with libgmp in your reported version (2.7 nor 2.7-hardfp) since libgmp is overlayed by ports/efikamx-arm repository. In newer versions there is an overlay to avoid these problems too. Can you verify your prt-get.conf setup and check that ports collections are right?

They should be:
efikamx-arm
core-arm
opt-arm
core
opt

Loading...